Queue compartilhada

O exemplo abaixo mostra como compartilhar de forma igual uma conexão de 10Mbps de download e 2Mbps de upload entre dois usuários na rede 192.168.0.0/24. Se o usuário A estiver fazendo um download a 2Mbps, o usuário B irá ter a disposição 8Mbps e vice-versa. Haverá situações em que ambos os usuários irão necessitar a banda máxima (10Mbps), então nestes casos, cada um irá receber 5Mbps cada. O mesmo é válido para o upload. Esta configuração é válida também para mais de 2 usuários.

Primeiramente, marque todo o tráfego que vem da rede local 192.168.0.0/24 com a marca users.

/ip firewall mangle add chain=forward src-address=192.168.0.0/24 \
   action=mark-connection new-connection-mark=users-con
/ip firewall mangle add connection-mark=users-con action=mark-packet \
   new-packet-mark=users chain=forward

Agora adicione dois novos tipos PCQ. O primeiro, chamado pcq-download agrupará todo o tráfego pelo endereço de destino. Como iremos associar este tipo de queue a interface local, será criada uma queue dinâmica para cada endereço de destino (ip do usuário) que estiver fazendo download na rede 192.168.0.0/24. O segundo tipo PCQ, chamado pcq-upload, agrupará o tráfego por endereço de origem. Iremos associar esta queue a interface publica para que seja criada uma queue dinâmica para cada usuário que estiver fazendo upload a internet a partir da rede 192.168.0.0/24.

/queue type add name=pcq-download kind=pcq pcq-classifier=dst-address
/queue type add name=pcq-upload kind=pcq pcq-classifier=src-address

Ao final, faremos uma queue tree para o tráfego de download:

/queue tree add name=Download parent=Local max-limit=10240000
/queue tree add parent=Download queue=pcq-download packet-mark=users

E para upload:

/queue tree add name=Upload parent=Public max-limit=2048000
/queue tree add parent=Upload queue=pcq-upload packet-mark=users

Fonte: http://www.mikrotik.com/testdocs/ros/3.0/qos/queue_content.php#.6.3